Yamaha Discussions about Yamaha ATVs.

Yamaha TerraPro Help

  #1  
Old 05-28-2019, 10:07 AM
Weekend Warrior
Thread Starter
Join Date: May 2019
Posts: 1
Default Yamaha TerraPro Help

I have had my Terrapro for a little over a year now. I used it all last summer to mow around 4 acres without issue, besides replacing belts. I have used it since as just a 4 wheeler this winter and spring and it has ran fine using the thumb throttle. This last weekend I attempted to mow with the Terrapro, and as soon as I engage the lever throttle, the engine constantly surges and runs horribly. I removed the carburetor and soaked it in pinesol for a day. It still starts and runs great on the thumb throttle, but horribly on the lever. I removed the lever throttle linkage to the thumb throttle, and it still runs horribly as soon as the lever throttle engages the transmission.

I noticed there is another "throttle plate" after the carburetor in the intake. It appears that the only input to this "throttle plate" control module is transmission speed signal from a cable. It my issue likely due to a fault with this "module" between the intake and carb? Any tips before tearing into it?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
timmymacnj
Yamaha
8
09-02-2015 05:57 AM
CHUCKY112233
Yamaha
1
08-11-2009 04:00 PM
drumachine
Yamaha
4
05-06-2007 10:14 PM
BushHog
Yamaha
4
11-28-1999 03:27 AM

Currently Active Users Viewing This Thread: 4 (0 members and 4 guests)
 

Thread Tools
Search this Thread
Quick Reply: Yamaha TerraPro Help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: