KFX50 (LT-A50) overheating? - ATVConnection.com ATV Enthusiast Community

Kids Quads Discussions about Kid's Quads and other ATV's.

KFX50 (LT-A50) overheating?

  #1  
Old 12-02-2018, 03:33 PM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 23
Default KFX50 (LT-A50) overheating?

Now that the kids quad is getting use, Iím finding a strange issue. It appears to be overheating and killing. Seems strange, but itís just like you hit the kill switch. The only thing consistent is it happens after running for awhile, kills like you accidentally hit the kill switch, then wonít start right away. After it seems to cool a bit, it will fire on the first pull and run as if nothing was ever wrong until it happens again which occurs much quicker now.

any suggestions on what I should be looking at? Spark plug cap and wire may be suspect, running a 5 plug. Restrictors removed and head shaved. Been sub freezing here, possibly running lean (67.5 main jet)
thanks
 
  #2  
Old 12-03-2018, 03:11 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,612
Default

Is it getting enough oil? It could be nipping up then freeing as it cools. However it could also be an ignition problem. Check the kill switches, the "sink plug" type can deteriorate and cause trouble. Check the wiring, and fit a new plug. If that doesn't fix it, the coil or exciter may be faulty, difficult to check with intermittent faults. Not sure if the LTA has a CDI as well, the LT50 doesn't.
 
  #3  
Old 12-03-2018, 01:43 PM
Weekend Warrior
Thread Starter
Join Date: Oct 2018
Posts: 23
Default

Originally Posted by merryman View Post
Is it getting enough oil? It could be nipping up then freeing as it cools. However it could also be an ignition problem. Check the kill switches, the "sink plug" type can deteriorate and cause trouble. Check the wiring, and fit a new plug. If that doesn't fix it, the coil or exciter may be faulty, difficult to check with intermittent faults. Not sure if the LTA has a CDI as well, the LT50 doesn't.
I guess its possible. Ive been considering bypassing the OI for awhile. Just filled the Oil tank with Amsoil Dominator when I picked it up. hardly put a tank of gas through it yet. Id like to take a look at the plug. Could def be very lean with the mods Ive done to it. since its winter, I can take some more time to work on it.

FWIW, it does run pretty good. I go 275 and I was pulling the 35lb kid in a sled behind it in snow covered grass. Sounds opposite of the LT-Z50 reviews
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
untraceable
Kids Quads
17
11-09-2018 06:45 AM
Barrera90504
Suzuki
2
12-08-2014 10:04 AM
selector
Yamaha
1
09-17-2003 10:36 PM
Delmustator
Kids Quads
5
07-29-2003 04:53 PM
RickyA
Kids Quads
4
06-26-2003 11:55 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: KFX50 (LT-A50) overheating?


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: