Suzuki Discussions about Suzuki ATVs.

99 quadrunner 250 lt260f help please

  #1  
Old 12-01-2018, 07:26 PM
Trailblazer
Thread Starter
Join Date: Dec 2006
Posts: 58
Likes: 0
Received 0 Likes on 0 Posts
Default 99 quadrunner 250 lt250f help please

im helping a buddy get this thing working. ive never worked on a suzuki, only polaris. currently it starts nice and easy, idles perfect. as soon as you press the throttle it spits and sputters and chugs.

he said a month ago it ran fine. 2 weeks later he went to use it and he said mice chewed some wires and caused
the cdi to go bad creating a no spark condition. he replaced the cdi with aftermarket and it runs as i described above. besides the cdi hes done a carb kit, spark plug and petcock.

quick glance i noticed the battery is not charging, 12.3 volts at idle. i saw a few internet posts about suzukis not running right if the voltage regulator isnt working, is this accurate? how do i test the voltage regulator?

am i going down the right path? any other things i should be checking?
 
  #2  
Old 12-02-2018, 03:02 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,844
Likes: 0
Received 4 Likes on 4 Posts
Default

I would be checking all the wiring for damage. A wrong CDI may give those symptoms too, so be doubly sure it is the right one, and that the carb was rebuilt right. Check the voltage with the engine at various revs, not just at idle. I had an Eiger a couple of weeks ago that had stood outside for two years waiting for a re-bore. Got the engine overhauled and started it up, wouldn't rev, in fact would hardly run at all. after hours of messing with carb etc, I showed the "boss's" son what it was doing, he was stood behind it when I started it up. "Nothing coming out of the exhaust" he said, I suddenly twigged, blocked exhaust, took the silencer off and it ran fine. I can only think, rodents have filled the silencer with something, but can't get anything out.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kazumanewb
Suzuki
2
12-05-2012 11:27 AM
Ozarkrider03
Suzuki
1
05-26-2003 11:27 PM
blazer316
Suzuki
7
07-18-2000 03:11 PM
Quadracer4
Suzuki
1
06-05-2000 04:06 PM
cls601
Suzuki
1
02-17-2000 11:46 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 99 quadrunner 250 lt260f help please


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: