Prairie 360 Belt Keeps slipping - ATVConnection.com ATV Enthusiast Community


Go Back   ATVConnection.com ATV Enthusiast Community > Brand Discussions Area > Kawasaki
Search

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-21-2007, 04:30 AM
Weekend Warrior
 
Join Date: Oct 2007
Posts: 7
Default Prairie 360 Belt Keeps slipping

Hey Guys,

I have a '03 Prairie 360 and I have replaced the belt now 3 times and it still wants to slip and "howl" when climbing a hill or just taking off fast. Is there a way to adjust the tension of the belt? Or do I have a different problem?

I had an EPI clutch kit on with a new Dayco belt and about 10 miles into a ride the belt broke. Then I found out that the Dayco belts are not very good. I replaced that with a factory Kawasaki belt and pulled the EPI clutch kit off and reinstalled the factory clutch, and it still want to slip and "howl" at me.

Any help is great.

Thanks
Jooser
Reply With Quote
  #2  
Old 10-21-2007, 11:01 PM
harry1's Avatar
Trailblazer
 
Join Date: Nov 2006
Posts: 72
Default Prairie 360 Belt Keeps slipping

Did the machine slip at all prior to the EPI clutch kit install? Could be alignment.
Reply With Quote
  #3  
Old 10-22-2007, 12:39 AM
Pro Rider
 
Join Date: Dec 2003
Posts: 1,057
Default Prairie 360 Belt Keeps slipping

Well, i bet that you have never adjusted your belt have you. If your belt is loose, your belt will slip. Try this. Go to nyrocatv.com and go to the tech tips section. In the prairie section you will find out how to check and adjust the belt. Also, make sure you are using low gear when supposed to. Are you?
Reply With Quote
  #4  
Old 10-22-2007, 04:06 AM
Weekend Warrior
 
Join Date: Oct 2007
Posts: 7
Default Prairie 360 Belt Keeps slipping

Yes the belt was slipping before the EPI Clutch install. That is when I replaced the belt with the Dayco belt and while I was doing that I thought that I would install the clutch kit too.

No....I have not adjusted my belt and yes I do use low gear, but the hills that I was talking about the belt slipping on were very slight slopes that I would normally think that someone would use low range for.

Thanks for the web site for belt adjustment tech tips.

Jooser
Reply With Quote
  #5  
Old 10-22-2007, 02:31 PM
Pro Rider
 
Join Date: Dec 2003
Posts: 1,057
Default Prairie 360 Belt Keeps slipping

make sure to keep us updated and see if its a problem solved.
Reply With Quote
  #6  
Old 10-26-2007, 10:41 PM
Weekend Warrior
 
Join Date: Oct 2007
Posts: 7
Default Prairie 360 Belt Keeps slipping

I will keep you up to date. I haven't had a chance to look at it yet, but soon I hope.
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 Prairie hesitates/bogs down only at light throttle hueby Kawasaki 1 11-06-2015 11:34 AM
Parts on Prairie not on Kawasaki parts list ReconBayou Kawasaki 2 10-19-2015 02:06 AM
highlanger 110 questions info cant find buddieboy Chinese Quads 3 09-27-2015 08:55 PM
Decisions decisions!!! XxS0ccerstarxX Polaris 1 09-24-2015 05:38 PM


Tags
03, 2007, 360, 4x4, adjust, adjustment, belt, broke, install, kawasaki, prairie, slipping, tension, tighten, tightening


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:49 PM.


This forum is owned and operated by Internet Brands, Inc., a Delaware corporation. It is not authorized or endorsed by the Ford Motor Company and is not affiliated with the Ford Motor Company or its related companies in any way. FordŽ is a registered trademark of the Ford Motor Company