No power in neutral light or ignition switch - ATVConnection.com ATV Enthusiast Community

1) Engine problems.. If your quad wont run..post in here.

No power in neutral light or ignition switch

  #1  
Old 01-13-2019, 10:27 PM
Weekend Warrior
Thread Starter
Join Date: Jan 2019
Posts: 1
Default No power in neutral light or ignition switch

I have a 99 Yamaha Timberwolf 250 and I have no power in the neutral light or ignition switch. I do get power to my head lights. It has a good battery and fuse is good. What should I start with? Thanks in advance.
 
  #2  
Old 01-14-2019, 04:22 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,513
Default

Fairly sure the ignition switch also turns the lights on and off, so I think you are getting power to and from the ignition switch. Try to get hold of the wiring diagram, and trace the neutral light circuit back to the ignition switch. There is a lock-out that prevents the starter working unless the neutral light is on, which makes this circuit very complex. You would be better posting in the Yamaha section by the way.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jm91rs
Kids Quads
3
12-31-2018 02:16 PM
Ratsnestii
Arctic Cat
2
12-23-2018 06:33 PM
Megamole
Polaris
11
12-21-2018 03:12 PM
Lyle1984
Technical and How-To Articles
0
12-12-2018 09:28 AM
James Merritt
Yamaha
2
11-20-2018 02:20 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: No power in neutral light or ignition switch


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: