Suzuki Discussions about Suzuki ATVs.

Lt80 spark problem

  #1  
Old 12-11-2018, 09:58 PM
Weekend Warrior
Thread Starter
Join Date: Nov 2018
Posts: 5
Default Lt80 spark problem

My lt80 project I thought was coming to a end but I can't get spark but only after i let off the starter switch. Brand New cdi, stator, and ignition coil. I haven't tested any of them but can. Someone told me a parking brake problem but it is cranking right?
Video is attached of problem.
 
Attached Files
File Type: mpg
20181211_211439.mpg (3.19 MB, 13 views)
  #2  
Old 12-12-2018, 03:52 AM
Extreme Pro Rider
Join Date: Oct 2013
Location: Lancaster England
Posts: 3,730
Default

This is a strange fault that affects a lot of bikes with CDI ignition. Never been able to find out what causes it. As the ignition circuit is completely separate from the battery setup, the starter "draw" should have no affect whatsoever on the ignition, yet your video shows it happening. I guess some strange earthing fault may stop power going through the earths, check them, and disconnect the kill wire. If that doesn't work, substitute the old ignition parts back on the bike, one at a time, and let us know which fixes the problem.
 
  #3  
Old 12-12-2018, 08:10 AM
Extreme Pro Rider
LT80 Expert
Join Date: Mar 2001
Posts: 7,918
Default

Try a extra ground wire from motor to frame.
 
  #4  
Old 12-12-2018, 08:31 AM
Weekend Warrior
Thread Starter
Join Date: Nov 2018
Posts: 5
Default

Thanks guys really - Later ill try and run a extra ground and check other grounds also
 
  #5  
Old 02-05-2019, 07:38 AM
Weekend Warrior
Join Date: Feb 2019
Posts: 4
Default

Have you checked the stator with a meter? The first new stator I put in was bad from the factory. Also check continuity of wires point to point with a meter if you have one to make sure connections are good.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Just My Luck!!!
1) Engine problems..
13
01-29-2017 02:34 AM
tackabbott
Kids Quads
2
06-27-2011 10:04 AM
f250
Polaris
1
11-22-2006 12:20 PM
QIKER
Suzuki
7
11-14-2006 05:54 PM
NovaKaw650
Kids Quads
16
11-26-2003 12:25 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Lt80 spark problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: