Electric Starter will not work? - ATVConnection.com ATV Enthusiast Community



Reply
 
Thread Tools Search this Thread
  #1  
Old 11-14-2009, 04:37 PM
Trailblazer
Thread Starter
 
Join Date: Jan 2009
Posts: 46
Default Electric Starter will not work?

I have a 1985 Yamaha 225DR and it starts fine with pull start but the electric start button when I push it does even make a "click" sound? Any ideas? I check through the wiring and didnt see any disconnections or anything...
Reply With Quote
  #2  
Old 11-14-2009, 06:15 PM
Speedy2222's Avatar
Elite Pro Rider
Is A Power Sport Junkie!
 
Join Date: Jul 2003
Location: Indiana
Posts: 5,399
Default

bad solenoid or bad starter.. it is fast clicking it's froze starter or dead battery. it may also have a dead battery but usually yamahas click very fast when it's just dead unless it's completely gone
Reply With Quote
  #3  
Old 11-14-2009, 06:42 PM
Trailblazer
Thread Starter
 
Join Date: Jan 2009
Posts: 46
Default

My bad I ment to write it doesnt even make a "click" sound. Lol sorry but even when I hooked the battery charger up to the battery and cleaned the poles it still didnt do anything at all when i hit the e start buttomn
Reply With Quote
  #4  
Old 11-14-2009, 06:46 PM
Trailblazer
Thread Starter
 
Join Date: Jan 2009
Posts: 46
Default

Oh yea the neutral light wont come on either
Reply With Quote
  #5  
Old 11-14-2009, 10:04 PM
nickmon3's Avatar
Trailblazer
 
Join Date: Nov 2009
Posts: 51
Default

probably dead battery try jumping it and if that wont work check ur fuses
Reply With Quote
  #6  
Old 11-14-2009, 10:27 PM
Trailblazer
Thread Starter
 
Join Date: Jan 2009
Posts: 46
Default

I did hook a battery charger up to it so its not dead battery ill check fuses in a bit or tomorrow
Reply With Quote
  #7  
Old 11-14-2009, 11:40 PM
Speedy2222's Avatar
Elite Pro Rider
Is A Power Sport Junkie!
 
Join Date: Jul 2003
Location: Indiana
Posts: 5,399
Default

check the neutral safety switch. not sure where it is on that bike but it's my guess. My guess is check fuses and check starter
Reply With Quote
  #8  
Old 11-15-2009, 12:03 AM
Trailblazer
Thread Starter
 
Join Date: Jan 2009
Posts: 46
Default

I cheked over the whole wiring earlier and the only odd thing i saw was eletric tape holding 2 different color wires together I undid it and kept touching them and still nothing. Ill check fuses, starter(i heard i could connet the battery charger to the starter diretly and try that), and ill look for the neutral switch
Reply With Quote
  #9  
Old 11-15-2009, 02:10 PM
Speedy2222's Avatar
Elite Pro Rider
Is A Power Sport Junkie!
 
Join Date: Jul 2003
Location: Indiana
Posts: 5,399
Default

ya put the ( - ) on the frame and then put the( + ) on the pole on the starter and it should crank
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Mini hummer no start tweeder Kids Quads 6 07-05-2015 01:57 PM
2008 sportsman 500 new front Hd springs Mphillips Polaris 2 07-02-2015 07:20 PM
Lt160 transmission issue. bikedad3 Suzuki 2 07-02-2015 02:15 AM
Necht 2004 merryman Chinese Quads 1 06-27-2015 03:31 AM
92 bayou 300 motor change momofo Kawasaki 3 05-27-2015 12:06 PM


Tags
atv , bear , big , electric , fuses , neutral , pull , replace , safety , start , starter , switch , warrior , wont , work , yamaha


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:34 PM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send